There is an issue with Clinically Speaking / Dragon Medical One
Incident Report for Shared Services Status Page
Resolved
The Clinically Speaking (Dragon Medical) services have been restored.
Posted Jul 22, 2024 - 15:19 PDT
Investigating
Reported at 6:47 a.m. Friday, July 19, Clinically Speaking (Dragon Medical) is experiencing an outage. The company is aware and working to restore service.
Posted Jul 19, 2024 - 08:21 PDT
This incident affected: UNLV Health IT Services and Applications.