AV Issue - 625 Shadow Lane #134
Incident Report for Shared Services Status Page
Resolved
The AV equipment in 625 Shadow Lane (MEB) room 134 is working as expected.
Posted Jul 22, 2024 - 15:28 PDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2024 - 14:15 PDT
Investigating
The AV equipment in MEB room 134 is not working as expected. The AV Services team is working to resolve the issue.

Room 134 is still usable and a member of the AV Services team will be present to assist at the start of classes.
Posted Jul 12, 2024 - 15:03 PDT
This incident affected: Locations (625 Shadow Lane).