Classroom Microphone Issue - 625 Shadow Lane

Incident Report for Shared Services Status Page

Resolved

As of 1:35 p.m., the microphones are working as expected.
Posted Jul 07, 2025 - 15:57 PDT

Investigating

As of 9:59 a.m. on Monday, July 7, the classroom microphones at MEB are not working as expected. SOM AV Services is aware and working to resolve the issue.
Posted Jul 07, 2025 - 10:28 PDT
This incident affected: Locations (625 Shadow Lane).