Network Services Down - 1640 E. Flamingo Rd.
Incident Report for Shared Services Status Page
Resolved
Network connectivity at 1640 E. Flamingo Rd. has been restored.
Posted Nov 07, 2024 - 15:21 PST
Investigating
Network services are currently down at 1640 E. Flamingo Rd. (Shannon West Homeless Youth Shelter). SOM IT is aware and is working to restore service.
Posted Nov 04, 2024 - 06:49 PST
This incident affected: Locations (1640 East Flamingo Rd).