Network Connectivity - 1720 S. Maryland

Incident Report for Shared Services Status Page

Resolved

The network connection at 1720 S. Maryland is now stable.
Posted Oct 09, 2025 - 09:48 PDT

Investigating

As of 3:05 p.m. on Wednesday, October 8, the network at 1720 S. Maryland is experiencing intermittent connectivity issues. SOM IT is monitoring the issue.
Posted Oct 08, 2025 - 15:54 PDT
This incident affected: Locations (1720 S. Maryland Pkwy).