Phones Outage - 4000 E. Charleston Suite 206

Incident Report for Shared Services Status Page

Resolved

Phone service has been restored to 4000 E. Charleston, Suite 206.
Posted May 19, 2025 - 11:55 PDT

Investigating

As of 8:50 a.m. on Monday, May 19 the phones at 4000 E. Charleston Suite 206 are without service. SOM IT is aware and working with Cox Communications to restore service.
Posted May 19, 2025 - 09:05 PDT
This incident affected: Locations (4000 E. Charleston Blvd).