Phone Issue - 5320 S. Rainbow, 1707 W. Charleston Suite 150

Incident Report for Shared Services Status Page

Resolved

We have not received any additional reports regarding the intermittent one-way audio issue.

If you experience this issue, please contact the SOM Help Desk and provide the following details:

-Your phone number
-The other party’s phone number
-Date of the call
-Approximate time of the call
Posted Aug 21, 2026 - 08:50 PDT

Investigating

Phone service is not working as expected. There is an intermittent audio issue impacting the ability for callers to hear staff after resuming an on-hold call.

SOM IT is working with Cox to resolve the issue.
Posted Jul 06, 2026 - 16:14 PDT
This incident affected: Locations (1707 W. Charleston Blvd, 5320 S. Rainbow Blvd).