Epic Payment Issues

Incident Report for Shared Services Status Page

Resolved

The MedEpay service is now working normally.
Posted Mar 09, 2026 - 12:24 PDT

Monitoring

As of 8:16am on Monday, March 9, MedEpay is currently experiencing an issue that may be impacting the ability to process transactions.

The vendor is working to resolve.
Posted Mar 09, 2026 - 08:35 PDT
This incident affected: UNLV Health IT Services and Applications.