Water leak at 3010 W. Charleston
Incident Report for Shared Services Status Page
Resolved
The water leak at 3010 W. Charleston, Suite 125 has been temporarily addressed and the suite is in use. The space will be updated during the ongoing tenant improvements.
Posted Apr 29, 2024 - 13:53 PDT
Investigating
At 11:00 a.m. Wednesday, April 24, a water leak was reported at 3010 W. Charleston. Facilities is onsite resolving the issue. The employee impacted by the leak has been moved to another location. The suite is still in use and accessible.
Posted Apr 24, 2024 - 12:14 PDT
This incident affected: Locations (3010 W. Charleston Blvd).