Phone Issue - 3016 W Charleston, Suite 205

Incident Report for Shared Services Status Page

Resolved

Phone service at 3016 W. Charleston, Suite 205 has been restored.
Posted Apr 02, 2026 - 10:33 PDT

Investigating

As of Wednesday, April 1 at 8:00 a.m., the phones at 3016 W Charleston, Suite 205 are not working as expected.
SOM IT is working with Cox Communications to resolve the issue.
Posted Apr 02, 2026 - 09:28 PDT
This incident affected: Locations (3016 W. Charleston Blvd).