Smartsheet not working as expected

Incident Report for Shared Services Status Page

Resolved

The access issue with Smartsheet has been resolved.
Posted Sep 11, 2026 - 16:20 PDT

Investigating

As of approximately 1:20 p.m., Smartsheet is investigating an access issue impacting all users. Users receive an error that says "We're having trouble reaching Smartsheet right now." Smartsheet is working to resolve the issue.
Posted Sep 11, 2026 - 13:31 PDT
This incident affected: UNLV Health IT Services and Applications and UNLV School of Medicine IT Services and Applications.