Power has been restored to all buildings. If you experience any issues with your computer, please restart before contacting the SOM Help Desk.
Posted Jul 02, 2025 - 07:26 PDT
Identified
NV Energy is working to restore power outages impacting several locations. Please be patient as sites may experience power loss or intermittent fluctuations. Where possible generators or batteries are providing supplemental power to specific equipment.
Known impacted locations: 700 Shadow Lane 625 Shadow Lane * Power restored 1524 Pinto Lane
If you experience any issues when power is restored, please restart your computer prior to contacting the SOM Help Desk.
Posted Jul 01, 2025 - 17:09 PDT
Update
Nevada energy has advised that power should be restored within 15 to 20 minutes (by 4:50 PM) at the MEB location.
Posted Jul 01, 2025 - 16:39 PDT
Investigating
Starting at 3:54 p.m. on Tuesday, July 1, a power outage was reported at the following locations: 700 Shadow Ln 625 Shadow Ln - operating on generator 1524 Pinto Ln - operating on battery If you experience any issues, please restart your computer prior to contacting the SOM Help Desk.