Credit card readers not working as expected

Incident Report for Shared Services Status Page

Resolved

Credit card readers are now performing as expected.

If you are still experiencing an issue, please reboot the device prior to contacting the SOM Help Desk.
Posted Nov 05, 2025 - 11:33 PST

Investigating

UNLV Health MedEpay reported possible issue with payment processing after an overnight update impacting credit card readers. If you encounter an issue using a credit card reader, please reboot the computer connected to the credit card reader prior to contacting the SOM Help Desk.
Posted Nov 05, 2025 - 09:47 PST
This incident affected: UNLV Health IT Services and Applications.