Microphone Issue - 625 Shadow Lane #235

Incident Report for Shared Services Status Page

Resolved

The microphones in MEB #235 are now working as expected.
Posted Feb 12, 2026 - 12:56 PST

Investigating

As of approximately 10:15 a.m. on Thursday, February 12, the microphones in MEB #235 are not working as expected. AV Services is investigating the issue.
Posted Feb 12, 2026 - 11:28 PST
This incident affected: Locations (625 Shadow Lane).