Power Outage - 3196 S. Maryland Blvd.
Incident Report for Shared Services Status Page
Resolved
At 6:15 p.m. on Friday, October 18, power was restored to 3196 S. Maryland Pkwy.
Posted Oct 21, 2024 - 06:58 PDT
Update
At this time there is no impact to network connectivity. NV Energy is working to restore service.
Posted Oct 18, 2024 - 15:42 PDT
Investigating
As of 2:34 p.m. on Friday, October 18, 3196 S. Maryland is experiencing a power outage. NV Energy is aware and is working to restore power.
Posted Oct 18, 2024 - 14:44 PDT
This incident affected: Locations (3196 S. Maryland Pkwy).