Conference Room Equipment Not Working As Expected - 1701 W. Charleston suite 400

Incident Report for Shared Services Status Page

Resolved

The conference room display is now performing as expected.
Posted May 07, 2025 - 14:18 PDT

Investigating

The conference room display at 1701 W. Charleston suite 400, room 22 will not remain on. SOM AV Services is aware and investigating the issue.
Posted May 07, 2025 - 13:23 PDT
This incident affected: Locations (1701 W. Charleston Blvd).