Google Meet Not Working As Expected

Incident Report for Shared Services Status Page

Resolved

Google has resolved the issue and Google Meet is now working as expected.
Posted Sep 08, 2025 - 12:08 PDT

Investigating

Google Meet is not working as expected (inconsistent connection issues). Google has confirmed they are investigating the issue. Employees can use Zoom as a workaround.
Posted Sep 08, 2025 - 11:05 PDT
This incident affected: UNLV Health IT Services and Applications and UNLV School of Medicine IT Services and Applications.