Video Wall Display Issue - 625 Shadow Lane

Incident Report for Shared Services Status Page

Identified

The AV Services team is working with the vendor to resolve a hardware issue in the video wall.
Posted May 18, 2026 - 13:46 PDT

Investigating

The video wall in the forum at 625 Shadow Lane (MEB) has 2 panels that are not working as expected. The AV Services team is aware and working to resolve.
Posted May 18, 2026 - 08:01 PDT
This incident affects: Locations (625 Shadow Lane).