Workday issue

Incident Report for Shared Services Status Page

Resolved

Workday is now working as expected.
Posted May 05, 2026 - 08:08 PDT

Investigating

As of 1:46 p.m. on Monday, May 4, the Workday website is not functioning as expected.

This service is maintained by a group outside of the School of Medicine.
Posted May 04, 2026 - 14:29 PDT
This incident affected: UNLV School of Medicine IT Services and Applications.