Epic Video Client Issue

Incident Report for Shared Services Status Page

Resolved

The issue impacting the Epic Video Client has been resolved.

If you are still experiencing an issue, please contact the SOM Help Desk.
Posted Sep 11, 2025 - 15:29 PDT

Investigating

There is an issue currently impacting the Epic Video Client. Employees may be unable to start a video visit and may see a "Something Went Wrong" message. Employees may need to make multiple attempts to successfully join a video visit.

The Epic Support team is currently investigating.
Posted Sep 11, 2025 - 10:45 PDT
This incident affected: UNLV Health IT Services and Applications.