Savance not functioning as expected

Incident Report for Shared Services Status Page

Resolved

Savance service has been restored and is accessible at https://cloud.savanceworkplace.com/
. If you continue to experience issues, please contact the SOM Help Desk.
Posted Oct 30, 2025 - 08:25 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 29, 2025 - 10:40 PDT

Investigating

As of 9:57 a.m. on Wednesday, October 29, Savance is not accessible through the main link or saved bookmarks. The vendor is aware and working to restore service. Savance is used by all Mojave Counseling locations. Employees can temporarily access Savance using any of the following links:

https://sw-iis1-prod.savanceworkplace.com/
https://sw-iis2-prod.savanceworkplace.com/
https://sw-iis3-prod.savanceworkplace.com/
https://sw-iis4-prod.savanceworkplace.com/
Posted Oct 29, 2025 - 10:33 PDT
This incident affected: UNLV Health IT Services and Applications and Locations (4000 E. Charleston Blvd, 6375 W. Charleston Blvd).