Life Safety System - 3016 W. Charleston

Incident Report for Shared Services Status Page

Resolved

The Fire/Life Safety System at 3016 W. Charleston is now working as expected.
Posted Feb 18, 2026 - 07:17 PST

Investigating

Due to a needed emergency repair, the alerts for the Fire/Life Safety System at 3016 W. Charleston may sound throughout the day. Facilities is aware and technicians should be on site this afternoon.
Posted Feb 17, 2026 - 10:20 PST
This incident affected: Locations (3016 W. Charleston Blvd).