Phone Outage - 2724 N. Tenaya

Incident Report for Shared Services Status Page

Resolved

As of 4:45 p.m., phones are working as expected.
Posted May 28, 2025 - 16:56 PDT

Investigating

As of approximately 3:40 p.m. on Wednesday, May 28, the phones at 2724 N. Tenaya are not working as expected. SOM IT is working with Cox Communications to resolve the issue.
Posted May 28, 2025 - 15:46 PDT
This incident affected: Locations (2724 N. Tenaya).