Internet Outage - 2724 N. Tenaya

Incident Report for Shared Services Status Page

Update

The current outage is also impacting the Cox phone service. SOM IT continues to investigate.
Posted Jul 28, 2026 - 08:18 PDT

Investigating

As of 7:40 a.m. on Tuesday, July 28, 2724 N. Tenaya has been experiencing a network outage.

SOM IT is aware and investigating.
Posted Jul 28, 2026 - 07:53 PDT
This incident affects: Locations (2724 N. Tenaya).