Network Outage - 1720 S. Maryland

Incident Report for Shared Services Status Page

Resolved

This incident has been resolved.
Posted May 30, 2025 - 09:54 PDT

Investigating

As of 8:20 a.m., Friday, May 30, the network at 1720 S. Maryland is unavailable. SOM IT is currently working to resolve the issue.
Posted May 30, 2025 - 08:35 PDT
This incident affected: Locations (1720 S. Maryland Pkwy).