Phone Issue - 1707 W. Charleston

Incident Report for Shared Services Status Page

Resolved

Phone services at 1701 W. Charleston, suite 190 are now working as expected.
Posted May 11, 2026 - 08:04 PDT

Investigating

As of 10:00 a.m. on Friday, May 1, phones at 1707 W. Charleston Suite 190 are not working as expected. SOM IT is working with Cox Communications to resolve the issue.
Posted May 04, 2026 - 16:32 PDT
This incident affected: Locations (1707 W. Charleston Blvd).