Cox Phone Service Unavailable - 2724 N. Tenaya

Incident Report for Shared Services Status Page

Resolved

Cox phone service has been restored at 2724 N. Tenaya.
Posted Dec 30, 2025 - 12:34 PST

Investigating

Since 11:00 a.m. on Tuesday, December 29, the Cox Phone service at 2724 N. Tenaya has been unavailable. SOM IT is aware and working with Cox to restore service.
Posted Dec 30, 2025 - 11:48 PST
This incident affected: Locations (2724 N. Tenaya).