Phones Issue - 2724 N. Tenaya

Incident Report for Shared Services Status Page

Resolved

Phone service at 2724 N. Tenaya has remained stable and the clinics have confirmed no further issues.
Posted Mar 19, 2025 - 14:06 PDT

Investigating

At 11:15 a.m. on Friday, March 14, the clinics at 2724 N. Tenaya reported issues making outbound phone calls. SOM IT is aware and working with Cox to restore service.
Posted Mar 14, 2025 - 11:25 PDT
This incident affected: Locations (2724 N. Tenaya).