MedEpay Issues With Credit Card Payments

Incident Report for Shared Services Status Page

Resolved

MedEpay credit card payment services are now working as expected. If you are still experiencing an issue, please reboot your device before contacting the SOM Help Desk.
Posted May 11, 2026 - 10:09 PDT

Investigating

Elevon is currently experiencing an issue with MedEpay credit card processing and card readers not connecting. SOM IT and the EHR team are aware and monitoring the situation.
Posted May 11, 2026 - 09:32 PDT
This incident affected: UNLV Health IT Services and Applications.