Phone Issue - 1707 W. Charleston, Suites 100, 160, 190

Incident Report for Shared Services Status Page

Resolved

Phone service has been restored to 1707 W. Charleston, suites 100, 160 and 190.
Posted Mar 10, 2026 - 08:33 PDT

Investigating

As of 8:57 a.m. on Monday, March 9, the phones at 1707 W. 1707 W. Charleston, Suites 100, 160, 190 are not working as expected. SOM IT is working with Cox Communications to resolve the issue.
Posted Mar 09, 2026 - 09:51 PDT
This incident affected: Locations (1707 W. Charleston Blvd).