Power Outage 1707 E. Charleston Blvd - Remote Desktop Computers
Incident Report for Shared Services Status Page
Resolved
Power has been restored to the 1707 W. Charleston remote desktop computers and they are back online. If you are still experiencing an issue, please contact the SOM Help Desk.
Posted Nov 18, 2024 - 07:36 PST
Investigating
There is a power outage impacting 1707 W. Charleston Blvd., suite 210. This includes the 1707 remote desktop computers. SOM IT is aware and working with Facilities to restore power.
Posted Nov 18, 2024 - 07:08 PST
This incident affected: Locations (1707 W. Charleston Blvd).