Street Closure - W. Charleston Blvd

Incident Report for Shared Services Status Page

Resolved

Access from W. Charleston Blvd to 1701 and 1707 W. Charleston has been restored.
Posted Mar 19, 2025 - 11:08 PDT

Investigating

At 6:30 a.m. on Wednesday, March 19, Las Vegas Metro Police have closed W. Charleston Blvd. from Westwood Dr. (in front of UMC) to the east side of Shadow Lane (in front of Wendy's). Access to the 1707 W. Charleston clinics is limited from W. Charleston, but can be reached off of the Shadow lane entrance through the neighborhood to the south.

Access to 1701 W. Charleston is unknown at this time.
Posted Mar 19, 2025 - 07:00 PDT
This incident affected: Locations (1701 W. Charleston Blvd, 1707 W. Charleston Blvd).