Printer Issue - 2724 N. Tenaya

Incident Report for Shared Services Status Page

Resolved

All printers at 2724 N. Tenaya are now working as expected.
Posted Jul 09, 2025 - 12:34 PDT

Investigating

As of 8:30 a.m. on Wednesday, July 9, multiple printers at 2724 N. Tenaya are not working as expected. SOM IT is aware and is investigating.

Impacted printers: prn2057, prn2059, prn2067
Posted Jul 09, 2025 - 09:03 PDT
This incident affected: Locations (2724 N. Tenaya).