Cox Phone Services Unavailable - 2724 N Tenaya

Incident Report for Shared Services Status Page

Resolved

As of 2:20 p.m., phone service has been restored.
Posted Oct 08, 2025 - 15:02 PDT

Investigating

As of 1:10 p.m. on Wednesday, October 8, Cox phone service is unavailable at 2724 N. Tenaya.

SOM IT is aware and is working with Cox to restore service.
Posted Oct 08, 2025 - 13:46 PDT
This incident affected: Locations (2724 N. Tenaya).