Phone Service Unavailable - 5320 S. Rainbow

Incident Report for Shared Services Status Page

Resolved

Phone service has been restored at 5320 S. Rainbow Blvd.
Posted Jan 07, 2026 - 13:30 PST

Investigating

Since 12:36 p.m. on Wednesday, January 7, the Cox phone service is unavailable at 5320 S. Rainbow. SOM IT is aware and working with Cox to restore service.
Posted Jan 07, 2026 - 13:07 PST
This incident affected: Locations (5320 S. Rainbow Blvd).