Water Shut Off - Westbay - 3010, 3014, 3016 W. Charleston

Incident Report for Shared Services Status Page

Resolved

The water at Westbay has been restored.
Posted Oct 21, 2025 - 13:33 PDT

Investigating

As of 11:45 a.m. on Tuesday, October 21, the water at the entire Westbay property has been shut off. The water is expected to be restored within the hour.

Impacted locations
3010 W. Charleston
3014 W. Charleston
3016 W. Charleston
Posted Oct 21, 2025 - 11:50 PDT
This incident affected: Locations (3010 W. Charleston Blvd, 3014 W. Charleston Blvd, 3016 W. Charleston Blvd).