Power Outage - 4000 E. Charleston Blvd

Incident Report for Shared Services Status Page

Resolved

This incident has been resolved.
Posted May 13, 2025 - 12:11 PDT

Update

Power, network and phone services have been restored at 4000 E. Charleston.
Posted May 13, 2025 - 12:10 PDT

Investigating

At 10:26 a.m. on Tuesday, May 13, 4000 E. Charleston was impacted by a power outage. All services are currently offline. NV Energy is currently investigating.

Once power is restored, if you are experiencing an issue, please restart your device and test prior to contacting the SOM Help Desk.
Posted May 13, 2025 - 10:46 PDT
This incident affected: Locations (4000 E. Charleston Blvd).