Phone outage at 1707 W. Charleston Plastics and General Surgery clinics
Incident Report for Shared Services Status Page
Resolved
At 9 a.m. 1707 W. Charleston clinics, Plastic Surgery and General Surgery, phone service was restored. The outage was due to a failed power supply.
Posted Oct 12, 2021 - 09:15 PDT
Identified
At 8 a.m. IT received reports that the 1707 W. Charleston clinics Plastic Surgery, suite 190, and General Surgery, suite 160, are experiencing a phone outage. IT is aware and working with Cox to restore service.
Posted Oct 12, 2021 - 08:47 PDT
This incident affected: Locations (1707 W. Charleston Boulevard).